


LabVIEWLabVIEW

LabVIEW je grafički programski jezik.

Za razliku od programskih jezika čija sintaksa je zasnovana na tekstu
LabVIEW koristi blokove umesto linija teksta.

Kod programa je dijagram koji se sastoji od čvorova i žica.
Podaci “putuju” preko žica.
Tok izvršavanja programa zavisi od protoka podataka, a ne Tok izvršavanja programa zavisi od protoka podataka, a ne koda!koda!



LabVIEWLabVIEW

LabVIEW je grafički programski jezik.

Za razliku od programskih jezika čija sintaksa je zasnovana na tekstu
LabVIEW koristi blokove umesto linija teksta.

Kod programa je dijagram koji se sastoji od čvorova i žica.
Podaci “putuju” preko žica.
Tok izvršavanja programa zavisi od protoka podataka, a ne Tok izvršavanja programa zavisi od protoka podataka, a ne koda!koda!

Novi način razmišljanja: datadata flowflow umesto codecode flowflow (chart flowchart flow)!!Novi način razmišljanja: datadata flowflow umesto codecode flowflow (chart flowchart flow)!!

Vodeći princip: čvor ne izvršava svoju funkciju sve dok podaci, preko 
žica ne “stignu” do ulaza u istižica, ne stignu  do ulaza u isti.



LabVIEWLabVIEW

LV programi se zovu virtualni instrumenti jer svojim izgledom 
podsećaju na fizičke instrumente, kao npr. osciloskope i multimetre. 

Ekstenzija programa pisanih u LV
*.vi (virtual instruments)



LabVIEWLabVIEW

LV programi se zovu virtualni instrumenti jer svojim izgledom 
podsećaju na fizičke instrumente, kao npr. osciloskope i multimetre. 

Ekstenzija programa pisanih u LV
*.vi (virtual instruments)

 Zbog prvenstvene primene kao mernih virtuelnih uređaja, LV sadrži 
b t bibli t k t ih f k ij k t l ih i t t kbogate biblioteke gotovih funkcija za kontrolu mernih instrumenata, kao 
i za prikupljanje, analizu, prezentaciju i skladištenje podataka.



Zašto koristiti LabVIEW?Zašto koristiti LabVIEW?

Jednostavan za učenje

Jednostavan za primenu

Programski kod je u vidu šeme

Nema sintakse!!!

Jednostavno i brzo ispravljanje grešaka 

Prilagodljiv



Pokretanje LabVIEW programa

Pokretanjem NI LabVIEW programa pojaviće se NI LabVIEW inicijalni prozor

Inicijalni prozor

1. Iz novog dokumenta:

Početak:

g
New»Blank VI

VI from Template

2. Iz postojećeg primera:
Examples»Find

ili

Examples»Find 
Examples…



LabVIEW programLabVIEW program
Svaki LabVIEW program (*(* vi) se sastoji iz dva dela:Svaki LabVIEW program ( .( .vi) se sastoji iz dva dela:

– front panel
– block diagram
 (* vi) uvek startuje sa front panelom ( .vi) uvek startuje sa front panelom

Front Panel Block DiagramFront Panel
korisnički interfejs

Block Diagram
Grafički kod

– Kontrole = Ulazi
– Indikatori = Izlazi

– Podaci “putuju” žicama  od kontrola 
preko funkcija do indikatora.



Front PanelFront Panel
korisnički interfejskorisnički interfejs

Front panel predstavlja korisnički interfejs 
programa.jj

– Kontrole = Ulazi
– Indikatori = Izlazi

programa.
Simulira panel fizičkog instrumenta.
Front panel sadrži:

– kontrole (okretna dugmad, klizači, tasteri,...)kontrole (okretna dugmad, klizači, tasteri,...)
– indikatore (grafikoni, displeji, skale,...)

 Kontole simuliraju ulazne delove uređaja i 
obezbjeđuju podatke za

block diagram vi programa.

Indikatori simuliraju izlazne delove uređaja iIndikatori simuliraju izlazne delove uređaja i 
služe za prikaz rezultata iz 

block diagram-a vi programa.

Svaki element front panela ima odgovarajući 
objekat u block diagramu.

Kontrole i indikatori dostupni su u okviru 
Controls palette front panela.



Dostupna je samo tokom rada na front panelu.
il đ j

Controls PaletteControls Palette
p j p

Ulaz/kontrola
Numeric

prilagođavanje 
izgleda palete

Numeric

Izlaz/Indicator:
Numeric Slide



Block DiagramBlock Diagram
Grafički kodGrafički kod Blok dijagram je grafički prikaz tela

– Podaci “se prenose” žicama od 
kontrola preko funkcija do 

Blok dijagram je grafički prikaz tela 
programa.

Za razliku od front panela koji jeindikatora. Za razliku od front panela koji je 
namenjen korisniku, 
blok dijagram je namenjen programeru.

Grafičko programiranje se vrši 
kreiranjem blok dijagrama sa već 
gotovim funkcijama koje se nalaze ugotovim funkcijama koje se nalaze u 
bibliotekama LabVIEW-a, gde se 
funkcije prilagođavaju potrebama 
podešavanjem izmenljivih parametara.p j j p

Glavni meni blok dijagrama u kome se 
nalaze funkcije – Functions palletej p



Dostupna je samo tokom rada na Blok dijagramu.

Functions PaletteFunctions Palette

S št j l t

p j j g

Smeštanje elemenata
u Block Diagram prozoru

While petljap j



Pretraga kontrola i funkcijaPretraga kontrola i funkcija

Palete su ispunjene stotinama kontrola iPalete su ispunjene stotinama kontrola i 
funkcija.

Kliknuti na taster za pretragu 

Pronaći željenu kontrolu ili funkciju

Kliknuti i prevući objekat iz prozora za 
bl k dij /f lpretragu na blok dijagram/front panel.



Pri pisanju programa u LabVIEW-u se koriste sledeće tri palete: 
1. Controls (Front Panel / View » Controls Palette)
2. Functions (Block diagram / View » Functions Palette),
3. Tools (View » Tools Palette).

T l P l
• PREPORUKA: Automatski izbor alatke

Al ti d i difik ij f t l i bl k dij bj k t

Tools Palette

• Alati za rad i modifikaciju front panel i blok dijagram objekata.

Automatic Selection Tool

O ti T l

 LabVIEV automatski bira odgovarajući alat sa palete Tools

Operating Tool

Positioning/Resizing Tool

Labeling Tool

Wiring Tool



Tools paletaTools paleta



Status ToolbarStatus Toolbar

Run Button 

Continuous Run Button

Abort Execution



Tehnike debagovanjaTehnike debagovanja

P i či
Run Button 

Prvi način

Greška u kodu → slomljena strelicaGreška u kodu    →   slomljena strelica
Klikom miša na strelicu pojavljuje se spisak grešaka u kodu

Drugi način
U Status Toolbar u klikom miša na “lampicu” a zatimU Status Toolbar-u klikom miša na lampicu , a zatim 
Pokrenuti program i posmatrati Blok Dijagram. 
Iznad “žica”, terminala, iza funkcija i potprograma se
pojavljuju tekuće vrednostipojavljuju tekuće vrednosti. 
Rad programa u ovom modu je usporen što omogućava 
detaljno praćenje izvršavanja koda.

Treći način
U paleti Tools izborom Probe Tool koji se postavi 
ga na onu “žicu” čija vrednost se posmatra pri 
izvršavanju. j
Pokrenuti program i posmatrati vrednost koja se 
javlja u “letećem” Probe prozoru.



Pomoć pri radu / Help

P i čiPrvi način LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples. 
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.



P i či L bVIEW d ži liki b j t ih i d k jih ž d ći

Pomoć pri radu / Help

Prvi način LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples.
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.

Drugi način Stati iznad funkcije za koju želite pogledati detaljnija 
objašnjenja i pritisnuti CTRL+H.



P i či L bVIEW d ži liki b j t ih i d k jih ž d ći

Pomoć pri radu / Help

Prvi način LabVIEW sadrži veliki broj gotovih primera do kojih se može doći 
na sledeći način: izabrati Help»Find Examples.
Pretraga je moguća po tematskim jedinicama i po ključnim rečima.

Drugi način Stati iznad funkcije za koju želite pogledati detaljnija 
objašnjenja i pritisnuti CTRL+H.

Treći način Na sajtu National Instruments-a postoji link ka NI Developer zoni 
(zone.ni.com) gde se mogu naći gotova rešenja konkretnih 
problema.



PRIMER PRIMER 11

Primer 1Primer 1--a:a:Primer 1Primer 1--a:a:

Kreirati virtuelni instrument koji:

1. Generiše testerasti signal.

2. Omogućava promenu amplitude signala iz Front panela.

3. Prikazuje signal na grafu Front panela.

LabVIEW sadrži ugrađene šablone virtuelnih instrumenata (templates) 

j g g p

g ( p )
koji mogu iskoristiti za većinu jednostavnih aplikacija za merenje. 

Za rešenje primera 1 koristiće se upravo jedan ovakav šablon. j p p j





Nakon odabira šablona pojavljuje se Front Panel... 



I ekran za kreiranje blok dijagrama virtuelnog instrumenta sa blokovima za 
generisanje i prikaz signala. 
Ovi blokovi su u odgovarajućoj sprezi sa kontrolama/indikatorima na FrontOvi blokovi su u odgovarajućoj sprezi sa kontrolama/indikatorima na Front 
Panelu. 



Blok Simulate Signal. 
1. Generisati testerasti signal

Desnim klikom na simbol ovog bloka se selektuje Properties, gde se nakon 
toga pojavljuje ekran za izmenu atributa bloka.



U okviru liste Signal Type izabrati tip generisanog signala Sawtooth što će 
rezultirati generisanjem testerastog signala.g j g g



 Dodavanje novih kontrola u okviru Front Panel-a se postiže selektovanjem

2. Omogućiti promenu amplitude signala iz Front panela.

 Dodavanje novih kontrola u okviru Front Panel a se postiže selektovanjem 
odgovarajuće iz palete kontrola. 



Kontrole su grupisane po kategorijama. 

U okviru Express kategorije selektovati Numeric Controls a zatim odabratiU okviru Express kategorije selektovati Numeric Controls, a zatim odabrati 
dugme (Knob) kontrolu i postaviti je na površinu panela (npr . pored grafa). 



Dugme (Knob) će biti iskorišćen za promenu amplitude generisanog signala.
Na radnoj površini Block Diagram editora nakon svih akcija nalaze se 
blokovi kao na sliciblokovi kao na slici.



Blok za simuliranje signala sadrži atribute koji se prikazuju nakon 
proširenja blok Simulate Signal.



Povezivanje Knob kontrole sa Simulate Signal Amplitude atributom se vrši 
njihovim “ožičavanjem”  (uspostavljanjem veze).



Startovanjem programa sa Run se može videti uticaj Knob kontrole na 
amplitudu generisanog signala.



Primer 1Primer 1--b:b:Primer 1Primer 1--b:b:

N f F t l ik tiNa grafu Front panela prikazati:

(1) generisan trouglasti signal,

(2) kao i signal čija je amplituda 10 puta veća od signala (1).





Uređivanje Block diagrama i prilagođavanje kontrola Front panela



Tri vrste funkcijaTri vrste funkcija
(Functions Palette)(Functions Palette)

Express VI: (plavi okvir)

To su interaktivni VI koji imaju svoj 
dijalog prozor iz koga je korisniku 
omogućeno da konfiguriše Express VI .

Standardni VI:

Funkcije: (žute boje) Osnovni elementi pomoću kojih su izgrađeni sviFunkcije: (žute boje) Osnovni elementi pomoću kojih su izgrađeni svi 
blokovi VI. Funkcije nemaju front panel ili blok dijagram.



Koje funkcije su dostupne?



Koje funkcije su dostupne?
 Ulaz/Izlaz

– Simulacija signala i podataka
– Akvizicija i generisanje signala korišćenjem uređaja za 

akviziciju podataka (DAQ)j p ( Q)

 Analiza
Ob d i l– Obrada signala

– Statistika
– Primena složenih matematičkih formula

 Skladištenje
Rad sa izlazno / ulaznim fajlovima– Rad sa izlazno / ulaznim fajlovima



KojKojee kkontrolontrolee i indikatori indikatorii su dostupni?su dostupni?

• Numerički podaci
– Numerički ulaz i izlaz

• Podaci Bulove logike
Express Controls Palette

Podaci Bulove logike
– Dugme i lampice

• Predstavljanje podataka
ički di l j– numerički displej

– 2D grafikon
– 3D grafikon

• Ukrašavanje
– strelice
– tabulatori

• Ostalo
– String and tekst boksovi



PetljePetlje

While While petljapetlja
• While petljeWhile petlje

– terminal broji iteracije
– Uvek se izvršava najmanje 

j djednom
– Izvršava se dok uslov za 

zaustavljanje nije ispunjen

• For petlje
t i l b ji it ij

For For petljapetlja
– terminal broji iteracije
– Izvršava se N - puta
u skladu sa ulaznim terminalom

p jp j



Unošenje/crtanje petlje u blok dijagramUnošenje/crtanje petlje u blok dijagram

1. Izbor iz Functions palete 2. Ograditi kod koji se ponavlja



Primer upotrebe While petljePrimer upotrebe While petlje



Donošenje odluka u LabVIEWDonošenje odluka u LabVIEW--uu

1. Case Structura

2 Select
(a) (b)

2. Select

(c)



Pristup podacima iz prethodne petljePristup podacima iz prethodne petlje
Shift Registar Shift Registar 

Unosi se desnim klikom miša na levi ili desni okvir petlje i odabirom opcije
Add Shift RegisterAdd Shift Register .

Desni terminal čuva podatke nakon završetka iteracije.
Levi terminal obezbeđuje sačuvan podatak na početku naredne iteracijie.j p p j

Krajnja 
vrednost

Inicijalna
vrednost 

Prva
iteracija

Druga
iteracija

Poslednja
iteracija



Ulazni i izlazni fajloviUlazni i izlazni fajlovi
 Omogućeno je snimanje podataka u fajl ili čitanje podataka iz fajla.

Upisivanje u .Upisivanje u .LVM LVM fajlfajl Čitanje iz .Čitanje iz .LVM LVM fajlafajla



Math Script čvor

 Mogu se implementirati tekstualne jednačine i algoritmi.
 Ulazne i izlazne promenljive se kreiraju na levoj i desnoj granici ’’ čvora’’.
 Kompatibilan je sa m-file script jezikom.

(Functions»Programming»
Structures»MathScript)



Akvizicija podatakaAkvizicija podataka
hhardverardverhhardverardver

Hardver za akviziciju je komponenta koja može da obavlja sledeće funkcije:
 Konverziju ulaznih analognih signala u digitalni format,o ve ju u a a a og s g a a u d g ta o at,
 Konverziju digitalnih signala u analogni format (izlaz),
 Generisanje digitalnih izlaznih signala.

 Uređaji za akviziciju podataka
(Data Acquisition Device - DAQ)

– USB, PCI ili PXI uređaji
– Konfigurišu se i testiraju u MAX-u

(Measurement & Automation Explorer)

 Zvučna kartica Zvučna kartica
– Ugrađena u većinu računara



Koji uređaj izabrati?Koji uređaj izabrati?

Sound Card NI USB DAQ NI PCI DAQSound Card NI USB DAQ NI PCI DAQ

AI Bandwidth 8–44 KS/s 10–200 KS/s 250 K–1.2 Ms/s
Accuracy 12–16 bit 12–16 bit 14–18 bit
Portable x x —
AI Channels 2 8–16 16–80
AO Channels 2 1 2 2 4AO Channels 2 1–2 2–4

NI USB-6009 SPECIFIKACIJA:
• 8  (14-bit) analognih ulaza
•12  digitalnih I/O linijag j
• 2   analogna izlaza



Akvizicija podataka u LabVIEWAkvizicija podataka u LabVIEW

Labview funkcije za akviziciju podataka (Data Acquisition VIs) se mogu
podeliti na:

- Express VIs (DAQ Assistant) iExpress VIs (DAQ Assistant) i
- Standard VIs (DAQmx VIs).

Express VIs (DAQ Assistant)Express VIs (DAQ Assistant)

 DAQ Assistant konfiguriše DAQ task korak po korak u nekoliko
konfiguracionih prozora. 



DAQmxDAQmx VVIIss

 Kada je brzina izvršavanja kritična, 
preporučuje se korišćenje
DAQmx VIs za akviziciju podataka. Q j p

 DAQmx VIs obuhvataju funkcije za
počinjanje i zaustavljanje akvizicije, 
čit j i i k i i i ih d t kčitanje i upis akvizicionih podataka.



Kreiranje virtuelnog voltmetraKreiranje virtuelnog voltmetra

F lFront panel

Block diagram



Block diagramBlock diagram

Formira virtuelni kanal
(AI Voltage)(AI Voltage)

Započinje merenje
Ponavlja podprogram – While petlja

Očitavanje podataka
Wait until next ms multiple

Uk lik d đ d šk j lj j
Zaustavlja merenje

Ukoliko dođe do greške, pojavljuje 
se dijalog boks sa informacijom o 
grešci koja se dogodila.



Zašto koristiti LabVIEW?Zašto koristiti LabVIEW?

Jednostavan za učenje

Jednostavan za primenu

Programski kod je u vidu šeme

Nema sintakse!!!

Jednostavno i brzo ispravljanje grešaka 

Prilagodljiv


